Kirby Software Forum
January 21, 2018, 03:01:35 AM *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Moved to new web hosting company
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Issues running as a service.  (Read 3054 times)
mmooreBRBH
Newbie
*
Posts: 3


« on: July 21, 2010, 07:35:56 PM »

I am having trouble getting Alarm Pro to run reliably as a service.  I am trying to use the app to send scheduled emails.  I have set it up and it shows up correctly in Services, but if I close the application, the emails do not go out.  As soon as I start the desktop app, the email goes out.  I have Service User Account Type set to Custom, and Service User Account Details set to an administrator account with log on as a service rights.

I just noticed that if I close the app, open Services, stop the service for about 15 seconds, then start it, the emails start going out.  This of course makes creating a new alarm very tedious.
« Last Edit: July 21, 2010, 09:05:10 PM by mmooreBRBH » Logged
Ian Cook
Administrator
Hero Member
*****
Posts: 919



WWW
« Reply #1 on: July 22, 2010, 01:37:12 AM »

Which version of windows are you using?
I'm afraid KA can only run as a service properly on windows XP.

In other operating systems, it still runs as service, BUT there is no desktop interaction (ie not icon no pop ups, etc etc) so I do not recommend it at all.


On a side note, I have recently updated to windows 7 64 bit and noticed the logout, reboot, shutdown was no longer working in win7.
This has been fixed. Apart from that it runs perfectly on windows 7 64 bit.

If you are interested you can download the update from http://www.kirbyfooty.com/kirby_alarm_pro_update_v4.48b.zip
Just unzip it to your KA folder.
(Don't forget to exit KA first or windows will complain the file is in use)

Ian  Smiley
Logged
mmooreBRBH
Newbie
*
Posts: 3


« Reply #2 on: July 22, 2010, 01:35:22 PM »

Windows Server 2003 32-bit SP2.  I am only interested in sending emails, not in desktop interaction.  I just want to be able to log in, add an email reminder and log out.  Right now, it only works if I restart the service after adding logging out.
Logged
Ian Cook
Administrator
Hero Member
*****
Posts: 919



WWW
« Reply #3 on: July 25, 2010, 12:45:30 PM »

Sorry for the delay in getting back to you.

I am a liitle confused.
Is the problem that you have to stop KA running as a service in order to add new alarms, OR, that KA is running as a service but the alarms you have already set up are not going out.

If the former then with no desktop interaction I understand that adding new emails etc to KA would be very tedious.
I am sorry but that is just the way it is.

If the latter, then once the recurring alarm is set up, providing KA is running as a service, the emails should be going out ok.
Are you sure KA is actually running as a service?
Check the windows service manager.
I would also try changing the service details to local and see how that goes.




* 1.jpg (35.94 KB, 421x470 - viewed 354 times.)

* 2.jpg (7.97 KB, 302x67 - viewed 341 times.)
« Last Edit: July 25, 2010, 04:59:38 PM by Ian Cook » Logged
mmooreBRBH
Newbie
*
Posts: 3


« Reply #4 on: July 26, 2010, 07:12:10 PM »

I have KA running correctly as a service.  I am only using it to send scheduled emails ("alarms").  If I remote to the system running KA, start the KA gui, add a new scheduled email and log out, all of the emails stop going out.  I have to restart the KA service to get them to start going out.  I am asking what the proper method is to add new scheduled emails when running KA as a service.  Having to restart the service just because I added a new alarm seems strange.
Logged
Ian Cook
Administrator
Hero Member
*****
Posts: 919



WWW
« Reply #5 on: July 27, 2010, 01:31:57 AM »

I am sorry but to be honest I do not know what to suggest.

I think the crux of the matter is that the way I wrote KA it is just one program.
That is why I say Windows XP is really the only operating system that KA can run as a service on.

To truely run as a service the program needs to be broken into two parts.
The gui part (ie the part that shows the icon, accepts new alarms, etc etc) AND the part that checks when alarms are due to be executed and then calls the appropriate program.
I do have plans to make the required change but it goiing to take a lot of work.

Given all that, I still would have thought that once an alarm has been set up that KA would execute it (providing the service was running of course)
I would not have thought you needed to restart the service each time.

I assume you have checked windows service manager to ensure KA is actually running?
There was also an update to the service template in the last update of KA. Have you install v4.48 yet?


Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!